Re: [PATCH 1/4] compcache: xvmalloc memory allocator

From: Nitin Gupta
Date: Mon Aug 24 2009 - 13:53:14 EST

Hi Pekka,

On 08/24/2009 11:03 PM, Pekka Enberg wrote:

[ Nit: the name xmalloc() is usually reserved for non-failing allocators in
user-space which is why xvmalloc() looks so confusing to me. Can we
get a better name for the thing? Also, I'm not sure why xvmalloc is a
separate module. Can't you just make it in-kernel or compile it in to the
ramzswap module? ]

xvmalloc is still a separate module to make sure I do not make it ramzswap

I am okay with renaming it to rzmalloc and compiling it with ramzswap instead
of as separate module. I will make these changes in next revision of these


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at