Re: [PATCH v5 1/3] ftrace: add tracepoint for timer

From: Xiao Guangrong
Date: Fri Aug 07 2009 - 08:15:53 EST


Ingo Molnar wrote:
* Xiao Guangrong <xiaoguangrong@xxxxxxxxxxxxxx> wrote:

Anton Blanchard wrote:
Hi,

Example ftrace output:
insmod-1712 [000] 145.901459: timer_init: timer=d0ace4b4
insmod-1712 [000] 145.901469: timer_start: timer=d0ace4b4 func=timer_fun expires=4294813629 timeout=199
<idle>-0 [000] 146.100230: timer_cancel: timer=d0ace4b4
<idle>-0 [000] 146.100233: timer_expire: timer=d0ace4b4 jiffies=4294813629
<idle>-0 [000] 146.100627: timer_callback_done: func=d0ace4b4
Sorry I haven't followed the thread, but I was wondering why you changed the name of the entry and exit tracepoints (ie timer_entry/timer_exit).

I think consistent naming is important to match the other static tracepoints, such as softirq_entry/softirq_exit, irq_entry/irq_exit and tasklet_entry/tasklet_exit.
I rename timer_entry/timer_exit to timer_expire/timer_callback_done just to match this series:

*_init() -> *_start() -> *_expire()...

It's a complete timer's lifecycle.

timer _handler_ entry/exit is a pretty good lifecycle name as well - and it nicely fits into the irq/softirq naming Anton mentioned. Maybe this list:


Hi Ingo,

Yeah, maybe you are right.
I'll fix those, or do you mind apply this patchset first and I'll send
a fix patch for those?

Thank you very much!
Xiao

timer_init
timer_start
timer_expire_entry
timer_expire_exit
timer_cancel

works for you Anton?

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/