Re: [PATCH] PM: Add convenience macro to make switching to dev_pm_ops less error-prone

From: Rafael J. Wysocki
Date: Wed Aug 05 2009 - 17:30:03 EST


On Wednesday 05 August 2009, Frans Pop wrote:
> Rafael J. Wysocki wrote:
>
> > +#define SIMPLE_DEV_PM_OPS(name, suspend_fn, resume_fn) \
> > +struct dev_pm_ops name = { \
> > + .suspend = suspend_fn, \
> > + .resume = resume_fn, \
> > + .freeze = suspend_fn, \
> > + .thaw = resume_fn, \
> > + .poweroff = suspend_fn, \
> > + .resume = resume_fn, \
>
> That defines .resume twice. Guess the last should be restore.

Yes, thanks to you and Philipp for noticing that and sorry for the mistake.

Rafael
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/