Re: [RFC v17][PATCH 10/60] c/r: make file_pos_read/write() public

From: KAMEZAWA Hiroyuki
Date: Wed Jul 22 2009 - 22:35:37 EST


a nitpick.

On Wed, 22 Jul 2009 05:59:32 -0400
Oren Laadan <orenl@xxxxxxxxxxx> wrote:

> These two are used in the next patch when calling vfs_read/write()

> +static inline loff_t file_pos_read(struct file *file)
> +{
> + return file->f_pos;
> +}
> +
> +static inline void file_pos_write(struct file *file, loff_t pos)
> +{
> + file->f_pos = pos;
> +}
> +

I'm not sure but how about renaming this to
file_pos()
set_file_pos()
at moving this to global include file ?

Thanks,
-Kame

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/