Re: PM/hibernate swapfile regression

From: Christoph Hellwig
Date: Tue Jul 21 2009 - 17:55:51 EST


On Tue, Jul 21, 2009 at 11:50:29AM +0100, Alan Jenkins wrote:
> +struct block_device *bdcopy(struct block_device *bdev)
> +{
> + atomic_inc(&bdev->bd_inode->i_count);
> + return bdev;
> +}
> +
> +EXPORT_SYMBOL(bdcopy);

The function name doesn't make any sense. You don't copy anything
here, but you grab a reference to it. A better name would be bdgrab,
mirroing the names of functions like igrab. A kerneldoc comment
documenting it would also be very helpful.

Why do you export it? The swapfile code is not actually modular.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/