Re: [PATCH] LED: Reply-To: use correct name for/sys/devices/virtual/leds/ entries

From: Richard Purdie
Date: Thu Jun 25 2009 - 07:00:01 EST


On Wed, 2009-06-24 at 15:33 -0700, Greg KH wrote:
> From: Olaf Hering <olh@xxxxxxx>
>
> This is needed to get kde-powersave to work properly on some g4
> powerbooks.
>
> From: Olaf Hering <olh@xxxxxxx>
> Signed-off-by: Greg Kroah-Hartman <gregkh@xxxxxxx>

I'm ok with this apart from:

> --- a/drivers/leds/ledtrig-default-on.c
> +++ b/drivers/leds/ledtrig-default-on.c
> @@ -23,7 +23,7 @@ static void defon_trig_activate(struct l
> }
>
> static struct led_trigger defon_led_trigger = {
> - .name = "default-on",
> + .name = "default::on",
> .activate = defon_trig_activate,
> };

which doesn't seem to match the patch description. Why does the trigger
name need to be changed?

Cheers,

Richard


--
Richard Purdie
Intel Open Source Technology Centre

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/