Re: [PATCH] pata_rdc: driver for RDC ATA devices

From: Joe Perches
Date: Wed Jun 24 2009 - 12:38:41 EST


On Wed, 2009-06-24 at 18:10 +0100, Alan Cox wrote:
> From: Alan Cox <alan@xxxxxxxxxxxxxxx>
> diff --git a/drivers/ata/pata_rdc.c b/drivers/ata/pata_rdc.c
> new file mode 100644
> index 0000000..0f40cab
> --- /dev/null
> +++ b/drivers/ata/pata_rdc.c
[]
> +static void rdc_set_piomode(struct ata_port *ap, struct ata_device *adev)
> +{
[]
> + static const /* ISP RTC */
> + u8 timings[][2] = { { 0, 0 },
> + { 0, 0 },
> + { 1, 0 },
> + { 2, 1 },
> + { 2, 3 }, };
[]
> +static void do_rdc_set_dmamode(struct ata_port *ap, struct ata_device *adev)
> +{
> + static const /* ISP RTC */
> + u8 timings[][2] = { { 0, 0 },
> + { 0, 0 },
> + { 1, 0 },
> + { 2, 1 },
> + { 2, 3 }, };

Maybe consolidate?

The code seems to have many magic constants that might
be better #define'd and or'd.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/