Re: [PATCH 2/3] arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.c: UseDO_ONCE & spelling fix

From: Dave Jones
Date: Thu May 21 2009 - 19:47:57 EST


On Thu, May 21, 2009 at 04:34:01PM -0700, Joe Perches wrote:
> On Thu, 2009-05-21 at 19:26 -0400, Dave Jones wrote:
> > On Thu, May 21, 2009 at 04:00:23PM -0700, Joe Perches wrote:
> > > diff --git a/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.c b/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.c
> > > index 208ecf6..f569cff 100644
> > > --- a/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.c
> > > +++ b/arch/x86/kernel/cpu/cpufreq/acpi-cpufreq.c
> > > @@ -693,8 +693,8 @@ static int acpi_cpufreq_cpu_init(struct cpufreq_policy *policy)
> > > if (perf->control_register.space_id == ACPI_ADR_SPACE_FIXED_HARDWARE &&
> > > policy->cpuinfo.transition_latency > 20 * 1000) {
> > > policy->cpuinfo.transition_latency = 20 * 1000;
> > > - printk_once(KERN_INFO "Capping off P-state tranision"
> > > - " latency at 20 uS\n");
> > > + DO_ONCE(printk(KERN_INFO
> > > + "P-state transition latency capped at 20 uS\n"));
> >
> > ewww. This looks pretty ugly to me. Anyone else?
>
> What look ugly?
>
> The macro use or the newline between KERN_INFO and "P-"
> or the reformatting of the quoted string?

I just think it's a less readable variant of the same thing.
The shouty macro, the extra level of brackets, the whole thing
just seems to be ugly to me with no redeeming feature.

What does doing this change really bring us?

Dave

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/