Re: [PATCH] Acer Aspire One Fan Control

From: Peter Feuerer
Date: Tue May 19 2009 - 02:53:09 EST


Hi Joe,

Joe Perches writes:

+#define acerhdf_printk(loglevel, fmt, args...) \
+ printk(loglevel "acerhdf: " fmt, ## args);
+
+#define acerhdf_notice(fmt, args...) \
+ acerhdf_printk(KERN_NOTICE, fmt, ## args);
+
+#define acerhdf_error(fmt, args...) \
+ acerhdf_printk(KERN_ERR, fmt, ## args);

Could you please not create new prefixes for printk?

I think:

#define pr_fmt(fmt) "acerhdf:" fmt
and use of pr_err and pr_notice would be better.

I could do that. Just curious, is there any deeper reason? Or does it just feel wrong in some matter?

best regards,
--peter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/