Re: [PATCH 1/5] mm: Add __GFP_NO_OOM_KILL flag

From: Andrew Morton
Date: Mon May 11 2009 - 20:18:26 EST


On Tue, 12 May 2009 01:28:15 +0200
"Rafael J. Wysocki" <rjw@xxxxxxx> wrote:

> On Tuesday 12 May 2009, Andrew Morton wrote:
> > On Tue, 12 May 2009 00:44:36 +0200
> > "Rafael J. Wysocki" <rjw@xxxxxxx> wrote:
> >
> > > Which means this patch:
> > > http://marc.info/?l=linux-kernel&m=124165031723627 (it also is my favourite
> > > one).
> >
> > ho hum, I could live with that ;)
> >
> > Would it make sense to turn it into something more general? Instead of
> > "tasks_frozen/processes_are_frozen()", present it as
> > "oom_killer_disabled/oom_killer_is_disabled()"?
> >
> > That would invite other subsystems to use it, if they want to. Which
> > might well be a bad thing on their behalf, hard to say..
>
> I chose the names this way because the variable is defined in the freezer code.
>
> Alternatively, I can define one in page_alloc.c, add [disable|enable]_oom_killer()
> for manipulating it and call them from the freezer code. Do you think that
> would be better?

The choice is:

a) put a general oom-killer interface function into the oom-killer
code, call that from swsusp.

b) put a swsusp-specific change into the oom-killer, call that from swsusp.


>From a cleanliess POV, a) is way better. But it does need to be a
general function! If there's some hidden requirement which only makes
the function applicable to swsusp, such as "all tasks must be frozen" then
we'd be kidding ourselves by making it general-looking.

I have a bad feeling that after one week and 12^17 emails, we're back
to your original patch :)

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/