Re: [patch] tracing/mm: add page frame snapshot trace

From: Wu Fengguang
Date: Sat May 09 2009 - 05:44:32 EST


On Sat, May 09, 2009 at 05:24:31PM +0800, Ingo Molnar wrote:
>
> * Wu Fengguang <fengguang.wu@xxxxxxxxx> wrote:
>
> > Hi Ingo,
> >
> > On Sat, May 09, 2009 at 02:27:58PM +0800, Ingo Molnar wrote:
> > >
> > > * Wu Fengguang <fengguang.wu@xxxxxxxxx> wrote:
> > >
> > > > > So this should be done in cooperation with instrumentation
> > > > > folks, while improving _all_ of Linux instrumentation in
> > > > > general. Or, if you dont have the time/interest to work with us
> > > > > on that, it should not be done at all. Not having the
> > > > > resources/interest to do something properly is not a license to
> > > > > introduce further instrumentation crap into Linux.
> > > >
> > > > I'd be glad to work with you on the 'object collections' ftrace
> > > > interfaces. Maybe next month. For now my time have been allocated
> > > > for the hwpoison work, sorry!
> > >
> > > No problem - our offer still stands: we are glad to help out with
> > > the instrumentation side bits. We'll even write all the patches for
> > > you, just please help us out with making it maximally useful to
> > > _you_ :-)
> >
> > Thank you very much!
> >
> > The good fact is, 2/3 of the code and experiences can be reused.
> >
> > > Find below a first prototype patch written by Steve yesterday and
> > > tidied up a bit by me today. It can also be tried on latest -tip:
> > >
> > > http://people.redhat.com/mingo/tip.git/README
> > >
> > > This patch adds the first version of the 'object collections'
> > > instrumentation facility under /debug/tracing/objects/mm/. It has a
> > > single control so far, a 'number of pages to dump' trigger file:
> > >
> > > To dump 1000 pages to the trace buffers, do:
> > >
> > > echo 1000 > /debug/tracing/objects/mm/pages/trigger
> > >
> > > To dump all pages to the trace buffers, do:
> > >
> > > echo -1 > /debug/tracing/objects/mm/pages/trigger
> >
> > That is not too intuitive, I'm afraid.
>
> This was just a first-level approximation - and it matches the usual
> "0xffffffff means infinite" idiom.

8^)

> How about changing it from 'trigger' to 'dump_range':

That's a better name!

> echo "*" > /debug/tracing/objects/mm/pages/dump_range
>
> being a shortcut for 'dump all'?

No I'm not complaining about -1. That's even better than "*",
because the latter can easily be expanded by shell ;)

> And:
>
> echo "1000 2000" > /debug/tracing/objects/mm/pages/dump_range
>
> ?

Now it's much more intuitive!

> The '1000' is the offset where the dumping starts, and 2000 is the
> size of the dump.

Ah the second parameter 2000 can easily be taken as "end"..

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/