Re: [PATCH 2/3] tracing/filters: distinguish between signed andunsigned fields

From: Ingo Molnar
Date: Wed Apr 29 2009 - 06:37:23 EST



* Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:

> On Tue, 28 Apr 2009 03:04:53 -0500 Tom Zanussi <tzanussi@xxxxxxxxx> wrote:
>
> > +#define is_signed(t) (((t)-1) < 0)
>
> geeze that was confusing until I worked out that `t' is supposed to be
> the name of a C type.

good point, i've changed its name to is_signed_type().

> is_signed(0) == true!
>
> whee.

I also added parantheses around the -1 literal to make it clear that
this is a cast.

> Rename it to is_signed_type() or something, please?

done.

Thanks,

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/