Re: [PATCH] Introduce a boolean "single_bit_set" function.

From: Andrew Morton
Date: Fri Apr 24 2009 - 13:49:21 EST


On Fri, 24 Apr 2009 06:40:39 -0400 (EDT) "Robert P. J. Day" <rpjday@xxxxxxxxxxxxxx> wrote:

> so it would be a simple matter to define the bit set boolean in
> terms of hweight_long(), yes? so what about, in bitops.h:
>
> static inline bool
> exactly_one_bit_set(unsigned long w)
> {
> return hweight_long(w) == 1;
> }
>
> static inline bool
> more_than_one_bit_set(unsigned long w)
> {
> return hweight_long(w) > 1;
> }
>
> or something to that effect, *if* people think it's worth it.
> obviously, none of the above is strictly necessary, but it would make
> a lot of code semantically cleaner.
>

Doing plain old

if (hweight32(foo) == 1)

(say) at the call sites quite clearly expresses what the code is trying
to do.

> rday
>
> p.s. i notice that, even in a single header file like bitops.h, there
> is a mixture of both "inline" and "__inline__". what's the
> recommended choice these days?

`inline'. Or uninline the function ;)
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/