Re: [PATCH 07/14] DRBD: internal_data_structures

From: Bart Van Assche
Date: Sun Apr 12 2009 - 12:45:09 EST


On Fri, Apr 10, 2009 at 2:12 PM, Philipp Reisner
<philipp.reisner@xxxxxxxxxx> wrote:
> diff -uNrp linux-2.6.30-rc1/drivers/block/drbd/drbd_int.h linux-2.6.30-rc1-drbd/drivers/block/drbd/drbd_int.h

...

> +#define PRINTK(level, fmt, args...) \
> +       printk(level "drbd%d: " fmt, \
> +               mdev->minor , ##args)

The above looks similar to dev_printk() from <linux/device.h>. It
would be great if some of the DRBD-specific macro's could be replaced
by existing Linux macro's. This would improve the readability of the
DRBD source code.

...

> +#define D_ASSERT(exp)  if (!(exp)) \
> +        ERR("ASSERT( " #exp " ) in %s:%d\n", __FILE__, __LINE__)
> +
> +#define ERR_IF(exp) if (({                             \
> +       int _b = (exp) != 0;                            \
> +       if (_b) ERR("%s: (%s) in %s:%d\n",              \
> +               __func__, #exp, __FILE__, __LINE__);    \
> +        _b;                                            \
> +       }))

How about replacing invocations of D_ASSERT() and/or ERR_IF() by WARN_ON() ?

Bart.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/