Re: [git-pull -tip] x86: cleanup 20090317

From: Jaswinder Singh Rajput
Date: Tue Mar 17 2009 - 04:51:14 EST


On Tue, 2009-03-17 at 09:38 +0100, Thomas Gleixner wrote:
> On Tue, 17 Mar 2009, Jaswinder Singh Rajput wrote:
> > On Mon, 2009-03-16 at 23:33 +0100, Thomas Gleixner wrote:
> > > On Tue, 17 Mar 2009, Jaswinder Singh Rajput wrote:
> > >
> > > > -static struct clock_event_device pit_clockevent = {
> > > > +static struct clock_event_device pit_dev = {
> > >
> > > Why do we need to change the name of the variable ? Just for fun or
> > > is pit_dev more self explaining than pit_clockevent ?
> >
> > pit already means it is a clock event, but with this change:
> >
> > 1. we save 8 characters per declaration
> > 2. It solves various 80 characters problem
>
> There is not a single 80 character problem in that file.

Here are 80 character problems:

1. pit_clockevent.mult = div_sc(CLOCK_TICK_RATE, NSEC_PER_SEC,
pit_clockevent.shift);
2. pit_clockevent.max_delta_ns =
clockevent_delta2ns(0x7FFF, &pit_clockevent);
3. pit_clockevent.min_delta_ns =
clockevent_delta2ns(0xF, &pit_clockevent);

4. clocksource_pit.mult = clocksource_hz2mult(CLOCK_TICK_RATE,
clocksource_pit.shift);


--
JSR

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/