Re: [RFC][PATCH] Reduce size of swap_cgroup by CSS ID

From: Li Zefan
Date: Thu Feb 05 2009 - 21:08:33 EST


> +/*
> + * A helper function to get mem_cgroup from ID. must be called under
> + * rcu_read_lock(). Because css_tryget() is called under this, css_put
> + * should be called later.
> + */
> +static struct mem_cgroup *mem_cgroup_lookup_get(unsigned short id)
> +{
> + struct cgroup_subsys_state *css;
> +
> + /* ID 0 is unused ID */
> + if (!id)
> + return NULL;
> + css = css_lookup(&mem_cgroup_subsys, id);
> + if (css && css_tryget(css))
> + return container_of(css, struct mem_cgroup, css);
> + return NULL;
> +}

the returned mem_cgroup needn't be protected by rcu_read_lock(), so I
think this is better:
rcu_read_lock();
css = css_lookup(&mem_cgroup_subsys, id);
rcu_read_unlock();
and no lock is needed when calling mem_cgroup_lookup_get().

> * Returns old value at success, NULL at failure.
> * (Of course, old value can be NULL.)
> */
> -struct mem_cgroup *swap_cgroup_record(swp_entry_t ent, struct mem_cgroup *mem)
> +unsigned short swap_cgroup_record(swp_entry_t ent, unsigned short id)

kernel-doc needs to be updated

> * lookup_swap_cgroup - lookup mem_cgroup tied to swap entry
> * @ent: swap entry to be looked up.
> *
> - * Returns pointer to mem_cgroup at success. NULL at failure.
> + * Returns CSS ID of mem_cgroup at success. NULL at failure.

s/NULL/0/

> */
> -struct mem_cgroup *lookup_swap_cgroup(swp_entry_t ent)
> +unsigned short lookup_swap_cgroup(swp_entry_t ent)



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/