[pull request] async function call updates

From: Arjan van de Ven
Date: Tue Jan 27 2009 - 11:51:35 EST


Hi Linus,

please pull the following 4 patches for the async code; they contain
two bugfixs (although the current kernel won't hit it in practice),
documentation and a rename of the "special" API to be more clear




The following changes since commit
5ee810072175042775e39bdd3eaaa68884c27805: Linus Torvalds (1):
Fix "multiple definition of `debugfs_create_size_t'"

are available in the git repository at:

ssh://master.kernel.org/pub/scm/linux/kernel/git/arjan/linux-2.6-async-update.git master

Cornelia Huck (4):
async: Fix running list handling.
async: Handle kthread_run() return codes.
async: Add some documentation.
async: Rename _special -> _domain for clarity.

fs/super.c | 4 +-
include/linux/async.h | 8 +++--
kernel/async.c | 81
+++++++++++++++++++++++++++++++++++++++++------- 3 files changed, 76
insertions(+), 17 deletions(-)

--
Arjan van de Ven Intel Open Source Technology Centre
For development, discussion and tips for power savings,
visit http://www.lesswatts.org
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/