Re: [patch] SLQB slab allocator

From: Joe Perches
Date: Thu Jan 22 2009 - 22:59:59 EST

On Fri, 2009-01-23 at 04:35 +0100, Nick Piggin wrote:
> That's a fair point. Hugh dislikes it too, I see ;) What to do... I
> had been toying with the idea that if slqb (or slub) becomes "the"
> allocator, then we could rename it all back to slAb after replacing
> the existing slab?

maybe SLIB (slab-improved) or SLAB_NG or NSLAB or SLABX
Who says it has to be 4 letters?

> Or I could make it a 128 bit allocator and call it SLZB, which would
> definitely make it "the final" allocator ;)

That leads to the phone book game.

SLZZB - and a crystal bridge now spans the fissure.

Hmm, wrong game.

cheers, j

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at