Re: [2.6.29-rc2][Suspend regression][DRM ???? bisected]

From: etienne
Date: Mon Jan 19 2009 - 16:05:29 EST


etienne wrote:

With 2.6.29-rc2 (and rc1) i cannot resume from suspend to ram (echo mem > /sys/power/state). Computer correctly suspends, but never wakes up (screens stays black and everything is unresponsive)
It has been working flawlessly in all prior kernel.
I tried a bisection and it "seems" to point to :
a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9 is first bad commit
commit a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9 Author: Dave Airlie <airlied@xxxxxxxx> Date: Sun Dec 7 12:02:21 2008 +1000 drm: reorganise start and load.
Make sure we have the primary node so the device can add maps.
Signed-off-by: Dave Airlie <airlied@xxxxxxxxxx> ========================================

HOWEVER, I am not quite sure my bisect was correct; I mean, some "bad bisect" had a different behavior (resume produces a garbage screen, computer locked)
and after bisect 57a6297e52b32ff402291a7d8fd802f83e746e52 all "bad" kernel wouldn't start X, init=/bin/bash booted fine but no resume

I tried to revert but got errors
etienne@etienne-desktop:~/linux-2.6$ git revert a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9
warning: too many files, skipping inexact rename detection
Auto-merged drivers/gpu/drm/drm_stub.c
CONFLICT (content): Merge conflict in drivers/gpu/drm/drm_stub.c
Automatic revert failed. After resolving the conflicts,
mark the corrected paths with 'git add <paths>' or 'git rm <paths>' and commit the result.
Please find attached bisect log, lspci (from 2.6.28-rc8) , and .config (2.6.29rc2)

I have a radeon card
01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300(PCIE)]
Packages :
xserver-xorg-video-radeon 1:6.9.0+git20081003.f9826a56-0ubuntu2.1
ii xserver-xorg 1:7.4~5ubuntu3 the X.Org X server ii xserver-xorg-core 2:1.5.2-2ubuntu3 Xorg X server - core server I'm willing to test patches and ideas of course :)

Except for this regression, everything works fine for me, I migrated to ext4 and it "feels" a huge win especially on "rm" and fsck :))

best regards,


as my bisect directed to drm but as I was unable to revert the commit, I took my 2.6.29rc2 kernel, removed drivers/gpu/drm and include/drm and replaced them with 2.6.28 files.
Rebooted into this new kernel, suspended to ram and ...same bug :(
so maybe there a bug in drm, but there another one elsewhere...
I checked /var/log/messages from a working and a non working kernel, and there's absolutely _nothing_ in non-working kernels
in working kernel i see suspend beginning like this :
Jan 19 21:50:47 etienne-desktop kernel: PM: Syncing filesystems ... done.
Jan 19 21:50:47 etienne-desktop kernel: [drm] Num pipes: 1

Are there any patch i could try?
Is it possible to run a git bisect excluding all drm commits to find the other bug?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at