Re: [Patch] slob: clean up the code

From: Matt Mackall
Date: Sun Jan 18 2009 - 14:43:40 EST

On Mon, 2009-01-19 at 02:00 +0800, AmÃrico Wang wrote:
> - Use NULL instead of plain 0;


> - Rename slob_page() to is_slob_page();


> - Define slob_page() to convert void* to struct slob_page*;

Ok. The general "struct page vs page" confusion isn't really improved by
this but at least this makes it a bit less ugly.

> - Rename slob_new_page() to slob_new_pages();

Don't care about this one. We've long had a notion of a "high order
page" (singular) of size 2^n pages.

> - Define slob_free_pages() accordingly.

This is a trivial wrapper function with one user.

But this patch is probably fine in it's current form, I don't care
enough about the above to respin it.

Signed-off-by: Matt Mackall <mpm@xxxxxxxxxxx>

-- : development and support for Mercurial and Linux

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at