Re: [PATCH 7/9] ide: move ->rqsize init from init_irq() to ide_init_port()

From: Bartlomiej Zolnierkiewicz
Date: Wed Jan 14 2009 - 12:25:39 EST


On Sunday 11 January 2009, Sergei Shtylyov wrote:
> Hello.
>
> Bartlomiej Zolnierkiewicz wrote:
>
> > Signed-off-by: Bartlomiej Zolnierkiewicz <bzolnier@xxxxxxxxx>
> >
>
> > Index: b/drivers/ide/ide-probe.c
> > ===================================================================
> > --- a/drivers/ide/ide-probe.c
> > +++ b/drivers/ide/ide-probe.c
> >
> [...]
> > @@ -1242,6 +1234,13 @@ static void ide_init_port(ide_hwif_t *hw
> >
> > if (d->max_sectors)
> > hwif->rqsize = d->max_sectors;
> > + else {
> > + if ((hwif->host_flags & IDE_HFLAG_NO_LBA48) ||
> > + (hwif->host_flags & IDE_HFLAG_NO_LBA48_DMA))
> >
>
> Er, why not:
>
> if (hwif->host_flags &
> (IDE_HFLAG_NO_LBA48 | IDE_HFLAG_NO_LBA48_DMA))

IMO it is harder to read
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/