Re: [PATCH for -tip] irq: for_each_irq_desc() makes simplify

From: KOSAKI Motohiro
Date: Thu Dec 25 2008 - 08:45:32 EST


> [KOSAKI Motohiro - Thu, Dec 25, 2008 at 09:41:54PM +0900]
> ...
> | Is this good idea?
> | this patch also tested on above three architecture.
> |
> |
> | ===
> | Subject: [PATCH] irq: for_each_irq_desc() makes simplify
> | Impact: cleanup
> |
> | all for_each_irq_desc() usage point have !desc check.
> | then its check can move into for_each_irq_desc() macro.
> |
> |
> | Signed-off-by: KOSAKI Motohiro <kosaki.motohiro@xxxxxxxxxxxxxx>
> | CC: Yinghai Lu <yinghai@xxxxxxxxxx>
> | CC: Ingo Molnar <mingo@xxxxxxx>
> | ---
> | arch/x86/kernel/io_apic.c | 10 ----------
> | drivers/xen/events.c | 3 ---
> | fs/proc/stat.c | 3 ---
> | include/linux/irqnr.h | 6 ++++--
> | kernel/irq/autoprobe.c | 15 ---------------
> | kernel/irq/handle.c | 3 ---
> | kernel/irq/spurious.c | 5 -----
> | 7 files changed, 4 insertions(+), 41 deletions(-)
> ...
>
> Hi Kosaki,
>
> the idea is that good indeed but I wonder if it possible
> to explain that we skip empty 'desk' in for_each_... name
> itself. Maybe for_each_irq_desc_defined :) Or something
> more convenient word instead of "defined"?

"if (!desc) " mean this irqno don't have irq description.
so I think this name imply mean skipping no irq desctiption element.

Actually, on CONFIG_SPARSEIRQ, desc is filled in dynamically after booting.
then "defined" is a bit misleading word.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/