Re: "Artem Onair Comcard 11": Variation found!

From: Andrey Panin
Date: Fri Dec 05 2008 - 06:30:26 EST

On 338, 12 03, 2008 at 12:49:55PM +0100, Michael Jarosch wrote:
> Hi there!
> I recently bought a WLAN-PCMCIA-adaptor from Ebay, named "ARtem Onair
> Comcard 11", which is reported to work with linux on several places in
> the internet. Well - my special card doesn't work. But this is not a
> "How can I get my device to work with Linux" issue, I promise! I did
> some investigation about this card, which I want to tell you, and I hope
> that this will help someone of the kernel-team to get things right!

Can you try to load orinoco_cs driver by hand and then add PCMCIA id of
your card using command below ?

echo "0x3 0x0268 0x0003 0 0 0 0 0 0 0" >/sys/bus/pcmcia/drivers/orinoco_cs/new_id

> O.k. - here's what I found:
> My card's got an alternate label on the backside, saying:
> "CC-W11-EMB PC-ETS-128"
> The modalias of the card looks like this:
> #cat /sys/bus/pcmcia/devices/1.0/modalias
> pcmcia:m0268c0003f06fn00pfn00pa7CE6F45Bpb427B2E41pc3284C1FFpd00000000
> The PCMCIA-Subsystem of a recent Kernel (2.6.26) prints out:
> #pccard ident
> Socket 1:
> product info: "ARtem", "Onair", "Version 1.0", ""
> manfid: 0x0268, 0x0003
> function: 6 (network)
> When I plug this card to my Debian Laptop, there won't happen that much.
> No module is loaded. The kernel just prints out some stuff
> to /var/log/syslog, saying:
> kernel: pccard: PCMCIA card inserted into slot 1
> kernel: cs: memory probe 0xa0000000-0xa0ffffff: clean.
> kernel: pcmcia: registering new device pcmcia1.0
> No big surprise: There is no kernel module with a fitting modalias!
> I also tried this card with Deli-Linux 0.7, a distro, which is specially
> made for old Devices. It uses the kernel. There's also no
> module loading when plugging in the card - initially.
> In the PCMCIA configuration file /etc/pcmcia/config I found something
> interesting:
> card "ARtem Onair Version 1.0"
> #version "ARtem", "Onair", "Version 1.0"
> manfid 0x0268, 0x0001
> bind "orinoco_cs"
> which says to me that another Version of the ARtem Onair card with the
> same chipset, but another manfid would just work. I edited the file and
> changed the manfid from 0x0001 to 0x0003 and restarted the
> pcmcia-daemon. When I now plug the card in, the modules "orinoco_cs",
> "orinoco" and "hermes" are loaded and I get a network device, named
> eth0. Now I can do some configuration with iwconfig. I also tried
> changing the driver to "wavelan_cs" (because of an entry on
>, look here: ) -
> looks the same to me.
> I don't know if this card does perfectly work with this driver. Scanning
> (with "iwlist eth0 scanning") is not supported and I can get no
> WEP-connection with any accesspoints at home - simply because there
> aren't any accesspoints that supports WEP. There would be some WPA2-APs,
> but the package wpa-supplicant is not included in Deli-Linux. So: I
> haven't managed to get a wifi-connection with this card and these
> drivers!
> BUT: It doesn't seem to my that support for this card on a recent kernel
> is far away. And maybe someone with better capabilities than me should
> get this thing done.
> I'm very interested in helping! I want this device working, so don't
> hesitate asking me!
> greetings
> Mitsch Jarosch

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at