Re: [PATCH 1/8] badpage: simplify page_alloc flag check+clear

From: Christoph Lameter
Date: Tue Dec 02 2008 - 08:17:50 EST

On Tue, 2 Dec 2008, Hugh Dickins wrote:

> > But they are always clear on free. The checking is irrelevant.

Strange name.

> The one I really disliked was "PAGE_FLAGS" for an obscure
> subset of page flags, and have got rid of that.


> > If (page->flags & (all the flags including dirty and SwapBacked))
> > zap-em.
> That's exactly what I did, isn't it?

Yes but you added another instance of this. Can you consolidate all the
check and clears into one?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at