Re: [PATCH 1/7] mm: introduce simple_malloc()/simple_free()

From: Nick Piggin
Date: Mon Nov 17 2008 - 23:40:30 EST


On Monday 17 November 2008 18:13, Andrew Morton wrote:
> On Mon, 17 Nov 2008 15:43:59 +0900 "KOSAKI Motohiro"
<kosaki.motohiro@xxxxxxxxxxxxxx> wrote:
> > >> > (I'll rename simple_malloc/simple_free to kvmalloc/kvfree)
> > >>
> > >> I would prefer to find a way to say that one cannot select gfp_mask
> > >> with this API.
> > >
> > > I think gfp_mask must be passed explicitly.
> >
> > Agreed.
>
> It would only make sense if __vmalloc() can be called in atomic contexts.
>
> __vmalloc() cannot be called from irq contexts due to it taking
> non-irq-safe spinlocks.
>
> __vmalloc() kinda looks like it could be called from non-irq atomic
> contexts with GFP_ATOMIC, but I think it lies. For example,
> pud_alloc_one/pmd_alloc_one/etc use hard-wired GFP_KERNEL.

vmalloc/vfree / vmap/vunmap I think could now be made to be usable even
in irq context, I think. Freeing up vmalloc space with global tlb flush
can't be done from interrupt context, but now with the lazy unmapping,
you only have to mark the area as freed (and possibly kick off a thread
to do the actual unmapping).

I didn't actually add that, because yes it would increase overheads a
bit, and I would still prefer to wait for a real nice problem it solves
before adding such a capability...


> In which case this new allocation function can only be called from
> contexts where GFP_KERNEL can be used, hence we don't need to pass that
> in - it would be misleading to do so.
>
> In fact it's not immediately clear why __vmalloc() takes a gfp_t
> argument either?

Possibly a bugcheck for !GFP_WAIT || !GFP_FS || !GFP_IO, or a might_sleep()
or something would be a good idea to add...
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/