Re: [PATCH] x86: fix wakeup_cpu with numaq/es7000 v2

From: Cyrill Gorcunov
Date: Mon Nov 17 2008 - 12:52:43 EST


[Ingo Molnar - Mon, Nov 17, 2008 at 06:35:27PM +0100]
|
| * Cyrill Gorcunov <gorcunov@xxxxxxxxx> wrote:
|
| > [Ingo Molnar - Mon, Nov 17, 2008 at 05:52:24PM +0100]
| > |
| > | * Yinghai Lu <yinghai@xxxxxxxxxx> wrote:
| > |
| > | > Impact: fix wakeup path with numaq and es7000
| > |
| > | applied to tip/x86/quirks, thanks Yinghai!
| > |
| > | A couple of comments:
| > |
| > | > +static inline void inquire_remote_apic(int apicid)
| > | > +{
| > | > + if (apic_verbosity >= APIC_DEBUG)
| > | > + __inquire_remote_apic(apicid);
| > | > +}
| > |
| >
| > Btw, Ingo, Yinghai,
| >
| > it's a bit weird but I found that we use apic_verbosity
| > here to _do_ something (ie touching circuit) but on any
| > other cases apic_verbosity is just a additional logging
| > filter so -- what the initial apic_verbosity purpose was?
| > If it's just a logging filter (to which I'm more biased)
| > this case is plain wrong. But if apic_verbosity is not
| > like this -- then it's fine. Since I was not initial author
| > of the code -- I'm asking you :)
|
| the reason why it's dependent on apic_verbosity is that the
| inquire_remote_apic() function is a debug function which we only call
| if we fail to start up a secondary CPU.
|
| Perhaps renaming it to debug_print_remote_apic() would have made that
| more obvious.
|
| Ingo
|

Ah... I missed io_apic.c apic_verbosity usage, sorry for noise.
It's all fine! Thanks.

- Cyrill -
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/