Re: [PATCH 4/5] adt7473: Check inputs from sysfs writes

From: Randy Dunlap
Date: Fri Nov 07 2008 - 16:05:12 EST


Jean Delvare wrote:
> On Fri, 07 Nov 2008 12:49:34 -0800, Joe Perches wrote:
>> On Fri, 2008-11-07 at 11:20 -0800, Andrew Morton wrote:
>>>> +#define ROUND_DIV(x, divisor) (((x) + ((divisor) / 2)) / (divisor))
>>> It might make sense to rename this to ROUND_CLOSEST, fix the
>>> double-evaluation and whap it into kernel.h?
>> ROUND_HALF_UP?
>
> What would that supposedly mean?

Just go with DIV_ROUND_CLOSEST() or DIV_ROUND().
The _CLOSEST() is redundant to ROUND .. IMO.

--
~Randy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/