Re: [PATCH 1/2] ftrace: make dynamic ftrace more robust

From: Steven Rostedt
Date: Wed Oct 22 2008 - 07:29:14 EST



On Wed, 22 Oct 2008, Steven Rostedt wrote:
> >
> > > + /* kprobes was not the fault */
> > > + ftrace_kill_atomic();
> >
> > while at it, ftrace_kill_atomic() is a misnomer.
> >
> > Please use something more understandable and less ambigious, like
> > "ftrace_turn_off()". Both 'kill' and 'atomic' are heavily laden phrases
> > used for many other things in the kernel.

I agree with your "atomic" part but the 'kill' I do not. Yes, it is
unfortunate that Unix used 'kill' to send signals. But the Unix name is
the misnomer. The problem with a "ftrace_turn_off" or anything similar,
is that people will likely use it to temporarily disable ftrace when they
need to do some sensitive code that they can not allow tracing on.
Then they will be confused when they can not find a "ftrace_turn_on()".

We already use "disable" to shut down ftrace and put it back into the
"NOP" state. We have "stop" and "start" to stop function tracing quickly
(just a bit is set, no conversion of code).

I figured "kill" is self explanatory. You use it when you want to kill
ftrace and do not want it to come back. We have no "ftrace_resurrect"
(well, not yet ;-)

I think most developers know the "kill" meaning. If you do not like the
name, you can change it.

-- Steve
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/