Re: tty: usb-serial krefs - bad magic number for tty struct (188:0)

From: Alan Cox
Date: Tue Oct 21 2008 - 09:04:52 EST

On Tue, 21 Oct 2008 09:42:47 -0300
"Sergio Luis" <eeeesti@xxxxxxxxx> wrote:

> On Tue, Oct 21, 2008 at 9:38 AM, Alan Cox <alan@xxxxxxxxxxxxxxxxxxx> wrote:
> >> one of the problems was the tty_kref_put(tty) in
> >> usb_serial_port_work() [drivers/usb/serial/usb-serial.c], that was
> >> releasing the tty device. I removed that line and it _almost_ worked.
> >> well, it worked, but only _once_. If I stopped the daemon and tried to
> >
> > You removed a valid one not the erroneous one it seems.
> >
> > Unfortunately your bug report doesn't actually say _WHICH_ USB serial
> > driver you are using which makes it a bit hard to be sure I'm looking for
> > the right bug.
> >
> The device is a Huawei E220 USB modem. What kind of info can I provide
> to help you with this? would dmesg help?

Ok thanks. Thats useful for two reasons

1. I've sent Linus a patch which I think fixes it
2. I have an E220 as well and mine now behaves

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at