Re: Scheduler on C2D CPU and latest 2.6.27 kernel

From: Zdenek Kabelac
Date: Tue Oct 21 2008 - 07:29:24 EST

2008/10/21 Chris Snook <csnook@xxxxxxxxxx>:
> Zdenek Kabelac wrote:
>> Hi
>> Recently I'm noticing bad behavior of the CPU scheduler on my T61 (2GB,
>> C2D)
>> It looks like Linux concentrates all running tasks on one CPU and the
>> second cpu is sleeping.
>> With recent changes to DRI - glxgears went up to 840FPS but also takes
>> 100% (with Xorg) and when I run 'while :; do true; done' loop in
>> parallel frame rate drops to 300FPS.
>> But as I have C2D CPU I would expect that there should be no such
>> dramatic slowdown.
>> Xosview shows that only one CPU is fully loaded.
>> Here are my .config scheduler options:
>> # CONFIG_GROUP_SCHED is not set
>> # CONFIG_SCHED_MC is not set

I've also tested SMT=n MC=y - with same result

>> # CONFIG_NET_SCHED is not set
>> Am I missing something?
> You're running a loop that does nothing except create new tasks that have no
> scheduling history, and then disappear before the scheduler can migrate
> them.
> Try running 'openssl speed' to chew up CPU. I promise you the scheduler
> will behave very nicely.

Well - sorry you really shouldn't promise things you cannot guarantee.

It's obviously showing exactly same problem on my box.

And I should add that with 2.6.27-rc8 I do not experience this behavior.
Gears are showning 80% speed - but consumes only 25%
and bash loop or openssl speed task do not influence its speed.
(as expected with 2CPU machine)

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at