Re: [PATCH tip/tracing/markers] markers: simplifymarker_set_format()

From: Ingo Molnar
Date: Mon Oct 20 2008 - 09:30:41 EST

* Mathieu Desnoyers <mathieu.desnoyers@xxxxxxxxxx> wrote:

> * Lai Jiangshan (laijs@xxxxxxxxxxxxxx) wrote:
> >
> > current marker_set_format() is complex this patch simplify it,
> > and decrease the overhead of marker_update_probes().
> >
> Yep, I think I did put the format string after the name \0, which was
> rather tricky. I agree that such change makes the code more readable at
> the expense of doing 2 allocations per marker rather than one, but
> readability might be a good thing here.
> Thanks !
> Acked-by: Mathieu Desnoyers <mathieu.desnoyers@xxxxxxxxxx>

applied to tip/tracing/markers, thanks!

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at