Re: [RFC v5][PATCH 2/8] General infrastructure for checkpointrestart

From: Dave Hansen
Date: Mon Sep 15 2008 - 13:54:53 EST


On Sat, 2008-09-13 at 19:06 -0400, Oren Laadan wrote:
>
> +int cr_read_obj_type(struct cr_ctx *ctx, void *buf, int n, int type)
> +{
> + struct cr_hdr h;
> + int ret;
> +
> + ret = cr_read_obj(ctx, &h, buf, n);
> + if (!ret) {
> + if (h.type == type)
> + ret = h.parent;
> + else
> + ret = -EINVAL;
> + }
> + return ret;
> +}

This one has been bugging me a bit. This adds one net line of code and
I think it's much easier to read:

{
struct cr_hdr h;
int ret;

ret = cr_read_obj(ctx, &h, buf, n);
if (ret)
return ret;

ret = -EINVAL;
if (h.type == type)
ret = h.parent;

return ret;
}

-- Dave

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/