Re: [PATCH 0/4] add a helper function, is_buffer_dma_capable()

From: Ingo Molnar
Date: Wed Sep 10 2008 - 05:35:02 EST



* Joerg Roedel <joerg.roedel@xxxxxxx> wrote:

> On Wed, Sep 10, 2008 at 01:06:45AM +0900, FUJITA Tomonori wrote:
> > This patchset adds a trivial helper function, is_buffer_dma_capable()
> > and cleans up some IOMMU implementations. This function is to to see
> > if a memory region is DMA-capable or not with the arguments, the
> > dma_mask (or coherent_dma_mask) of a device and the address and size
> > of a memory region. It's useful for IOMMUs that don't do virtual
> > mappings at all times.
> >
> > The patch for swiotlb is a bug fix (the rest are just
> > cleanups). Currently, swiotlb doesn't take account of the size of a
> > memory region to see if if the memory region is DMA-capable.
>
> Good idea. This patchset increases the readability of the software
> dma-api implementations.
>
> Acked-by: Joerg Roedel <joerg.roedel@xxxxxxx>

applied to tip/x86/iommu:

2797982: swiotlb: convert swiotlb to use is_buffer_dma_capable helper function
49fbf4e: x86: convert pci-nommu to use is_buffer_dma_capable helper function
ac4ff65: x86: convert gart to use is_buffer_dma_capable helper function
636dc67: add is_buffer_dma_capable helper function

thanks!

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/