Re: [PATCH v2 05/13] PCI: cpci_hotplug: stop managinghotplug_slot->name

From: Scott Murray
Date: Tue Sep 09 2008 - 17:17:39 EST


On Tue, 9 Sep 2008, Matthew Wilcox wrote:

> On Tue, Sep 09, 2008 at 04:00:27AM -0600, Alex Chiang wrote:
> > We no longer need to manage our version of hotplug_slot->name
> > since the PCI and hotplug core manage it on our behalf.
> >
> > Now, we simply advise the PCI core of the name that we would
> > like, and let the core take care of the rest.
>
> > -static void
> > -make_slot_name(struct slot *slot)
> > -{
> > - snprintf(slot->hotplug_slot->name,
> > - SLOT_NAME_SIZE, "%02x:%02x", slot->bus->number, slot->number);
> > -}
> >
> >
> > + scnprintf(name, SLOT_NAME_SIZE, "%02x:%02x", bus->number, i);
> > +
> > hotplug_slot->private = slot;
>
> Unfortunately, our name is kind of crappy. Can we not give the user
> anything better than this? I can't seem to find the CompactPCI
> specification to see if we have a better name available.
>
> I wonder if we can use DMI data on this class of machine. Scott?

This is about all that can be done, unfortunately. I've never seen
anything useful with regards to this in DMI on the boards I've looked
at, and we would have to rework the board driver -> CPCI hotplug core
interface to pass that information along even if we could get it for
some boards. In general, it is a difficult problem to solve since the
same set of system master and peripheral boards in a different chassis
could very well be at different geographic addresses depending on where
the chassis vendor has placed the system master slot(s).

Scott


--
Scott Murray
SOMA Networks, Inc.
Toronto, Ontario
e-mail: scottm@xxxxxxxxxxxxxxxx
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/