[PATCH 0/4] add a helper function, is_buffer_dma_capable()

From: FUJITA Tomonori
Date: Tue Sep 09 2008 - 12:11:32 EST


This patchset adds a trivial helper function, is_buffer_dma_capable()
and cleans up some IOMMU implementations. This function is to to see
if a memory region is DMA-capable or not with the arguments, the
dma_mask (or coherent_dma_mask) of a device and the address and size
of a memory region. It's useful for IOMMUs that don't do virtual
mappings at all times.

The patch for swiotlb is a bug fix (the rest are just
cleanups). Currently, swiotlb doesn't take account of the size of a
memory region to see if if the memory region is DMA-capable.

=
arch/x86/kernel/pci-gart_64.c | 16 +++-------------
arch/x86/kernel/pci-nommu.c | 10 ++++++----
include/linux/dma-mapping.h | 5 +++++
lib/swiotlb.c | 15 ++++++++-------
4 files changed, 22 insertions(+), 24 deletions(-)


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/