Re: [PATCH] platform: add new device registration helper

From: Andrew Morton
Date: Thu Sep 04 2008 - 20:21:37 EST


On Fri, 5 Sep 2008 01:30:16 +0400
Dmitry Baryshkov <dbaryshkov@xxxxxxxxx> wrote:

> Add a helper that registers simple platform_device
> w/o resources but with parent and device data.
>
> This is usefull to cleanup platform code from code that
> registers such simple devices as leds-gpio, generic-bl,
> etc.
>

nits:

> include/linux/platform_device.h | 2 +
> 2 files changed, 49 insertions(+), 0 deletions(-)
>
> diff --git a/drivers/base/platform.c b/drivers/base/platform.c
> index 3f94039..fcd9f97 100644
> --- a/drivers/base/platform.c
> +++ b/drivers/base/platform.c
> @@ -391,6 +391,53 @@ error:
> }
> EXPORT_SYMBOL_GPL(platform_device_register_simple);
>
> +/**
> + * platform_device_register_data
> + * @parent: parent device for the device we're adding
> + * @name: base name of the device we're adding
> + * @id: instance id
> + * @data: platform specific data for this platform device
> + * @size: size of platform specific data
> + *
> + * This function creates a simple platform device that requires minimal
> + * resource and memory management. Canned release function freeing memory
> + * allocated for the device allows drivers using such devices to be
> + * unloaded without waiting for the last reference to the device to be
> + * dropped.

Should document the return value (tested with IS_ERR)

> + */
> +struct platform_device *platform_device_register_data(
> + struct device *parent,
> + const char *name, int id,
> + const void *data, size_t size)

Something like

struct platform_device *platform_device_register_data(struct device *parent,
const char *name, int id, const void *data, size_t size)

would be more typical.

> +{
> + struct platform_device *pdev;
> + int retval;
> +
> + pdev = platform_device_alloc(name, id);
> + if (!pdev) {
> + retval = -ENOMEM;
> + goto error;
> + }
> +
> + pdev->dev.parent = parent;
> +
> + if (size) {
> + retval = platform_device_add_data(pdev, data, size);
> + if (retval)
> + goto error;
> + }
> +
> + retval = platform_device_add(pdev);
> + if (retval)
> + goto error;
> +
> + return pdev;
> +
> +error:
> + platform_device_put(pdev);

Are you sure this can't trigger a !kobj->state_initialized warning in
kobject_put()?

> + return ERR_PTR(retval);
> +}
> +
>
> ...
>
> +extern struct platform_device *platform_device_register_data(struct device *,
> + const char *, int, const void *, size_t);

It's nice (IMO) to include the names of the args, for documentation
purposes. Obviously the surrounding code didn't agree.

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/