Re: [PATCH] x86: add apic probe for genapic 64bit v2

From: Ingo Molnar
Date: Tue Jul 22 2008 - 04:24:46 EST



* Yinghai Lu <yhlu.kernel@xxxxxxxxx> wrote:

> On Tue, Jul 22, 2008 at 12:13 AM, Ingo Molnar <mingo@xxxxxxx> wrote:
> >
> > * Ingo Molnar <mingo@xxxxxxx> wrote:
> >
> >> > v2: fix compiling when CONFIG_ACPI is not set
> >>
> >> applied to tip/x86/x2apic - thanks Yinghai.
> >>
> >> > +static struct genapic *apic_probe[] __initdata = {
> >> > + &apic_x2apic_uv_x,
> >> > + &apic_x2apic_phys,
> >> > + &apic_x2apic_cluster,
> >> > + &apic_physflat,
> >> > + NULL,
> >> > +};
> >>
> >> very nice generalization!
> >
> > btw.:
> >
> > apic_probe[i]->acpi_madt_oem_check
> >
> > should probably be renamed to something more neutral like "->probe" -
> > there's nothing ACPI about it and some weird boxes could use PCI or
> > other probing mechanisms to discover the type of APIC they want to use.
>
> 32bit has acpi_madt_oem_check and mps_oem_check
> 64bit should only have acpi_madt_oem_check

yeah.

It's just a small detail: what i mean is that the method itself should
eventually simply be renamed from "acpi_madt_oem_check" to "probe".
There's nothing ACPI about this exept the fact that most current "is
this the APIC driver we should be using" checks involve some sort of
ACPI discovery. This is a Linux abstraction and as such a more generic
name like "probe" sounds more appropriate.

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/