Re: macbook2,2 latest git mmconfig issues

From: Justin Mattock
Date: Sat Jul 19 2008 - 15:35:40 EST

On Sat, Jul 19, 2008 at 10:58 AM, Jack Howarth
<howarth@xxxxxxxxxxxxxxxxx> wrote:
> On Sat, Jul 19, 2008 at 10:15:52AM -0700, Justin Mattock wrote:
>> when using the boot options
>> debug initctl_debug vga=790
>> I'm able to see the hardisk is being mounted alsa
>> is activated netfiler is being activated, but then
>> just stops giving me the:
>> VFS cannot mount on root filesystem error
>> keep in mind this is when using "any" option
>> in PCI, when using MMCONFIG
>> im getting what you where getting
>> I'm just confused on how the system was working
>> without any errors with "Direct" in pci
>> and now none of the options are working.
>> The posotive side is better work this issue now,
>> rather than later. what I'll try is loading a fresh install
>> of nubuntu, and then compile the kernel with there .config
>> to see if I'm able to start. Also they added apparmor so I'm not sure if
>> this is causing problems as well.
>> --
>> Justin P. Mattock
> Justin,
> Just to be clear, you do have CONFIG_PCIEASPM unset in your .config,
> right? All 2.6.26 kernels I have tried (including tip) hang during the
> boot when built with that option.
> Jack

yep; didn't choose this option.
I'll check again to make sure.
just loaded a fresh 2.6.26 without any patches
just to be sure and still unable to mount VFS error
where can I find the patches you used that worked
to see if this works over here. Is there some place I should look in userspace
as well to see if I'm missing something?

Justin P. Mattock
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at