Re: [RFC PATCH] - scripts/CodingStyle_sizeof - standardize sizeofand [PATCH] drivers/infiniband - standardize sizeof(foo)

From: Joe Perches
Date: Tue Jul 01 2008 - 14:14:25 EST


On Tue, 2008-07-01 at 10:57 -0700, Roland Dreier wrote:
> This seems like needless churn to me. I personally prefer to see
> "sizeof foo" instead of "sizeof(foo)", since sizeof is not a function,
> and in any case I don't see much value in making this type of trivial
> change.

No value but standardization and ease of grep.

fyi: drivers/infiniband uses 3 different styles for sizeof.
Your preferred style is not the most frequently used.

$ grep -Pr --include=*.[ch] "\bsizeof\(" drivers/infiniband | wc -l
785
$ grep -Pr --include=*.[ch] "\bsizeof\s+\(" drivers/infiniband | wc -l
226
$ grep -Pr --include=*.[ch] "\bsizeof\s+[^\(]" drivers/infiniband | wc -l
523

cheers, Joe

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/