Re: Linux 2.6.26-rc5

From: Linus Torvalds
Date: Thu Jun 05 2008 - 12:19:28 EST




On Thu, 5 Jun 2008, Bjorn Helgaas wrote:
>
> for (i = 0; (res = pnp_get_resource(dev, IORESOURCE_MEM, i)); i++) {
> - if (res->flags & IORESOURCE_DISABLED)
> + if (res->flags & IORESOURCE_UNSET ||
> + res->flags & IORESOURCE_DISABLED)
> continue;

Umm. If I was a compiler, I'd be warning about this. You don't get a
warning about suggesting parentheses around the '&'?

Also, regardless of lack of warnings, the natural way to do this is to
just say

if (res->flags & (IORESOURCE_DISABLED | IORESOURCE_UNSET))
continue;

which is what any sane compiler would rewrite it to anyway, but since it's
not just more readable for computers, but for humans too, why not do it
that way?

Linus
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/