Re: [RFC PATCH 4/6] seq_file: add function to write binary data

From: Peter Oberparleiter
Date: Thu May 08 2008 - 03:42:26 EST


Alexey Dobriyan wrote:
> On Thu, May 08, 2008 at 12:17:57AM +0400, Alexey Dobriyan wrote:
>> > > + memcpy(m->buf + m->count, s, len);
>> > > + m->count += len;
>> > > + return 0;
>> > > + }
>> > > + m->count = m->size;
>> > > + return -1;
>> > > +}
>> > > +EXPORT_SYMBOL(seq_write);
>>
>> I'd call function seq_memcpy() though.
>
> Or even seq_blob().

Hm, in my opinion seq_write() would fit more into the already existing
naming scheme of seq_file interface functions. The beauty of the idea
behind seq_file is that a user can just pretend to write to the buffer
that is read by a userspace application without having to worry about
full buffers, partial reads or seeks. In this context, the read becomes
a write and function names such as seq_printf(), seq_putc(), seq_puts()
or the suggested seq_write() seem to best fit this idea.


Regards,
Peter
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/