Re: [PATCH 1/1] x86: fix text_poke

From: Mathieu Desnoyers
Date: Fri Apr 25 2008 - 12:16:57 EST


* Ingo Molnar (mingo@xxxxxxx) wrote:
>
> * Mathieu Desnoyers <mathieu.desnoyers@xxxxxxxxxx> wrote:
>
> > Woooow, just a sec here. I removed the atomicity test _because_ there
> > happen to be a case where it's safe to do non-atomic instruction
> > modification. If we do :
> >
> > 1) replace the instruction first byte by a breakpoint, execute an
> > instruction bypass (see the immediate values patches for detail)
> > 2) modify the instruction non-atomically
> > 3) put back the original instruction first byte.
> >
> > That's why I removed the BUG_ONs at the beginning of the function.
> > That's also why it's required to deal with page crossing.
>
> but the code as-is is nonsensical. It checks for:
>
> BUG_ON(len > sizeof(long));
>
> but then deals with page crossing...
>

That was in the initial version, before my patch, yes. I dealt with page
crossing at first, then added a more restrictive test to "play safe" (I
should have removed the page-crossing code at that point), but later on
noticed that there was a single case where it's valid to do non-atomic
updates, and it's when the execution flow is bypassed by a breakpoint
(as the immediate values are doing), so the last patch you have removes
the restrictive test and lets the page-crossing code in place.

> it should also rename text_poke_early() to text_poke_core(), and call
> _that_ from text_poke() if core_kernel_text(). From that alone the whole
> poke_text() function would look a whole lot cleaner.
>

hrm, I am not convinced it's safe to call vmap() very early at boot
time. In the immediate values implementation, I do call text_poke very
very early at boot to populate the initial values. Or maybe are you
proposing something different from what I currently understand ?

Mathieu

> Ingo

--
Mathieu Desnoyers
Computer Engineering Ph.D. Student, Ecole Polytechnique de Montreal
OpenPGP key fingerprint: 8CD5 52C3 8E3C 4140 715F BA06 3F25 A8FE 3BAE 9A68
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/