Re: [PATCH 5/5] ptrace: it is fun to strace /sbin/init

From: Roland McGrath
Date: Sun Mar 16 2008 - 18:32:03 EST


> Ptracing of /sbin/init is not allowed. Of course, this is very dangerous, but
> may be useful. Introduce the kernel boot parameter to allow this.

Personally I wouldn't mind losing all the ptrace/signals special cases for
init. (Just don't have a buggy init and expect not to crash, don't be root
and kill init, etc.) So this is fine by me. The conservative route of
changing it only with a boot option is the wise thing to do.

> Unless I missed something, ptrace_get_task_struct() is pointless. It does not
> need to check "pid == 1", ptrace_attach() does this. It doesn't need tasklist.

Agreed. It's a hold-over from when there was more hair in there.

> It should be replaced with the generic find_get_task_by_vpid() which does not
> exist yet.

I didn't see enough other uses to really warrant it. Most
find_task_by_vpid calls don't actually do get_task_struct.
Those that do want to do some other check inside rcu_read_lock
before deciding to bother with get_task_struct anyway.
So there is nothing wrong with ptrace just open-coding:

rcu_read_lock();
child = find_task_by_vpid(pid);
if (child)
get_task_struct(child);
rcu_read_unlock();

We are on the way soon to having no arch callers of ptrace_get_task_struct
left, so only the two kernel/ptrace.c uses will survive. (x86 and ia64
switchovers to arch_ptrace/compat_arch_ptrace are already in the pipeline,
and maybe s390 too.) So let's worry about the cleanup removing this
function once those wither away.


Thanks,
Roland
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/