Re: [rfc][patch 3/3] use SLAB_ALIGN_SMP

From: Pekka Enberg
Date: Mon Mar 03 2008 - 08:53:48 EST


Hi,

On Mon, Mar 3, 2008 at 3:46 PM, Nick Piggin <npiggin@xxxxxxx> wrote:
> > Maybe we need to use three flags to separate the meanings ?
> >
> > SLAB_HINT_SMP_ALIGN
> > SLAB_HINT_HWCACHE_ALIGN
> > SLAB_HWCACHE_ALIGN /* strong requirement that two objects dont share a
> > cache line */
>
> Possibly, but I'm beginning to prefer that strong requirements should
> request the explicit alignment (they can even use cache_line_size() after
> Pekka's patch to make it generic). I don't like how the name implies
> that you get a guarantee, however I guess in practice people are using it
> more as a hint (or because they vaguely hope it makes their code run
> faster :))

At least historically SLAB_HWCACHE_ALIGN has been just a hint,
although slab tries very hard to satisfy it (see the comments in
mm/slab.c). Why do we need stronger guarantees than that, btw?
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/