[patch 1/2] ELF: Use EI_NIDENT instead of numeric value

From: gorcunov
Date: Sun Feb 10 2008 - 07:49:18 EST


Signed-off-by: Cyrill Gorcunov <gorcunov@xxxxxxxxx>
---

elf.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Index: linux-2.6.git/include/linux/elf.h
===================================================================
--- linux-2.6.git.orig/include/linux/elf.h 2008-02-08 19:09:52.000000000 +0300
+++ linux-2.6.git/include/linux/elf.h 2008-02-10 10:49:54.000000000 +0300
@@ -208,7 +208,7 @@ typedef struct elf32_hdr{
} Elf32_Ehdr;

typedef struct elf64_hdr {
- unsigned char e_ident[16]; /* ELF "magic number" */
+ unsigned char e_ident[EI_NIDENT]; /* ELF "magic number" */
Elf64_Half e_type;
Elf64_Half e_machine;
Elf64_Word e_version;

--
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/