Re: [PATCHv3 6/7] [POWERPC] Rename commproc to cpm1 and cpm2_common.c to cpm2.c

From: Kumar Gala
Date: Fri Jan 25 2008 - 04:01:34 EST



On Jan 24, 2008, at 9:19 AM, Jochen Friedrich wrote:

Rename commproc.[ch] to cpm1.[ch] to be more consistent with cpm2. Also
rename cpm2_common.c to cpm2.c as suggested by Scott Wood. Adjust the
includes accordingly.

Signed-off-by: Jochen Friedrich <jochen@xxxxxxxx>
---
arch/powerpc/platforms/8xx/ep88xc.c | 1 +
arch/powerpc/platforms/8xx/mpc86xads_setup.c | 2 +-
arch/powerpc/platforms/8xx/mpc885ads_setup.c | 2 +-
arch/powerpc/sysdev/Makefile | 4 ++--
arch/powerpc/sysdev/{commproc.c => cpm1.c} | 4 ++--
arch/powerpc/sysdev/{cpm2_common.c => cpm2.c} | 3 +--
arch/powerpc/sysdev/micropatch.c | 2 +-
arch/ppc/8260_io/enet.c | 2 +-
arch/ppc/8xx_io/commproc.c | 2 +-
arch/ppc/8xx_io/enet.c | 6 +++---
arch/ppc/8xx_io/fec.c | 2 +-
arch/ppc/8xx_io/micropatch.c | 2 +-
arch/ppc/boot/simple/iic.c | 2 +-
arch/ppc/boot/simple/m8xx_tty.c | 2 +-
arch/ppc/kernel/ppc_ksyms.c | 2 +-
arch/ppc/platforms/mpc866ads_setup.c | 2 +-
arch/ppc/platforms/mpc885ads_setup.c | 2 +-
arch/ppc/syslib/mpc8xx_devices.c | 2 +-
arch/ppc/xmon/start_8xx.c | 2 +-

All of these files seem reasonable.

drivers/net/fec.c | 8 --------
drivers/net/fec.h | 2 +-

asm-m68knommu/commproc.h ?? these are only built on coldfire.

drivers/net/fec_8xx/fec_8xx-netta.c | 2 +-
drivers/net/fec_8xx/fec_main.c | 2 +-
drivers/net/fec_8xx/fec_mii.c | 2 +-
drivers/net/fs_enet/fs_enet.h | 2 +-
drivers/net/fs_enet/mac-fec.c | 2 +-
drivers/net/fs_enet/mac-scc.c | 2 +-

these seem ok.

drivers/serial/68360serial.c | 2 +-

I think this is using asm-m68knommu/commproc.h

drivers/serial/cpm_uart/cpm_uart_cpm1.h | 2 +-
include/asm-powerpc/{commproc.h => cpm1.h} | 8 ++++----
include/asm-ppc/{commproc.h => cpm1.h} | 8 ++++----
31 files changed, 40 insertions(+), 48 deletions(-)
rename arch/powerpc/sysdev/{commproc.c => cpm1.c} (99%)
rename arch/powerpc/sysdev/{cpm2_common.c => cpm2.c} (99%)
rename include/asm-powerpc/{commproc.h => cpm1.h} (99%)
rename include/asm-ppc/{commproc.h => cpm1.h} (99%)

Also, CC jgarizk since we will be touching netdev drivers. We've been pushing such updates via the powerpc tree's but its good that Jeff's aware.

- k

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/