Re: [PATCH 1/2] Massive code cleanup of sys_msync()

From: Randy Dunlap
Date: Tue Jan 15 2008 - 14:13:35 EST


On Tue, 15 Jan 2008 22:02:54 +0300 Anton Salikhmetov wrote:

> 2008/1/15, Christoph Hellwig <hch@xxxxxxxxxxxxx>:
> > On Tue, Jan 15, 2008 at 07:02:44PM +0300, Anton Salikhmetov wrote:

> > > @@ -33,71 +34,65 @@ asmlinkage long sys_msync(unsigned long start, size_t len, int flags)
> > > unsigned long end;
> > > struct mm_struct *mm = current->mm;
> > > struct vm_area_struct *vma;
> > > - int unmapped_error = 0;
> > > - int error = -EINVAL;
> > > + int error = 0, unmapped_error = 0;
> > >
> > > if (flags & ~(MS_ASYNC | MS_INVALIDATE | MS_SYNC))
> > > - goto out;
> > > + return -EINVAL;
> > > if (start & ~PAGE_MASK)
> > > - goto out;
> > > + return -EINVAL;
> >
> > The goto out for a simple return style is used quite commonly in kernel
> > code to have a single return statement which makes code maintaince, e.g.
> > adding locks or allocations simpler. Not sure that getting rid of it
> > makes a lot of sense.
>
> Sorry, I can't agree. That's what is written in the CodingStyle document:
>
> The goto statement comes in handy when a function exits from multiple
> locations and some common work such as cleanup has to be done.

CodingStyle does not try to cover Everything. Nor do we want it to.

At any rate, there is a desire for functions to have a single point
of return, regardless of the amount of cleanup to be done, so I agree
with Christoph's comments.


> The second part of requirement does not hold true for the sys_msync() routine.
>
> >
> > > + file = vma->vm_file;
> > > + if ((flags & MS_SYNC) && file && (vma->vm_flags & VM_SHARED)) {
> >
> > Given that file is assigned just above it would be more readable to test
> > it first.
>
> The second part of my solution changes this code, anyway.
>
> >
> > > + if (error)
> > > + return error;
> >
> > This should be an goto out, returns out of the middle of the function
> > make reading and maintaining the code not so nice.
>
> Sorry, I don't think so. No "common cleanup" is needed here.


---
~Randy
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/