Re: [PATCH] x86_64: cleanup setup_node_zones called by paging_initv2

From: Dave Hansen
Date: Wed Jan 09 2008 - 14:12:15 EST


On Wed, 2008-01-09 at 10:30 -0800, Yinghai Lu wrote:
>
> [PATCH] x86_64: cleanup setup_node_zones called by paging_init v2
>
> setup_node_zones calcuates some variable but only use them when
> FLAT_NODE_MEM_MAP is set
>
> so change the MACRO postion to avoid calculating.
>
> also change it to static

I just see the patch adding a net of one #ifdef (and 3 lines of .c
file), and I don't consider that a cleanup. :(

If you make the function static, and make sure to cover that Dprintk up
with the #ifdef, I think the compiler should take care of the rest and
just throw away the function. Then, you won't need to add the second
#ifdef. You can even kill the brackets in that for loop.

Also, if you're going to be mucking around in there, can you give
setup_node_zones() a better name? It doesn't exactly setup any zones
any more. alloc_node_mem_map(), perhaps? The comment above it is
bogus, too.

-- Dave

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/