Re: [PATCH -mm 18/43] powerpc compat_binfmt_elf

From: Arnd Bergmann
Date: Fri Dec 21 2007 - 14:36:52 EST


On Friday 21 December 2007, Kyle McMartin wrote:
> Just taking a stab that hch means,
>
> config BINFMT_COMPAT_ELF
>         def_bool n
>         depends on 64BIT
>

I'd call it COMPAT_BINFMT_ELF, for consistency with the file name.
Also, the definition and the depends are redundant if you expect the
option to be autoselected. You can do either of

config COMPAT_BINFMT_ELF
bool

or

config COMPAT_BINFMT_ELF
def_bool y
depends on COMPAT

The second option makes sense at the point where all architectures with
compat code are using the same compat_binfmt_elf code.

Arnd <><
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/