Re: [PATCH 1/2] i386: mce cleanup part1: functional change

From: Oleg Verych
Date: Tue Oct 09 2007 - 21:44:11 EST


On Tue, Oct 09, 2007 at 04:46:46PM -0400, Valdis.Kletnieks@xxxxxx wrote:
> On Tue, 09 Oct 2007 18:32:30 +0200, Oleg Verych said:
> > On Tue, Oct 09, 2007 at 06:06:05PM +0200, Joerg Roedel wrote:
> > > > cpu_has() returns int,
> > > > but would it be better to have something like
> > > >
> > > > if (!mce_disabled &&
> > > > !(c->x86_capability & (X86_FEATURE_MCA | X86_FEATURE_MCE)) {
> > > > printk(KERN_INFO "CPU%i: No machine check support available\n",
> > > > smp_processor_id());
> > >
> > > This looks complicated and is harder to read. Its exactly the purpose of the
> > > cpu_has() macro to avoid such constructs.
> >
> > It is done via test_bit(), which is designed for IO access with all that
> > `const volatile' stuff, 2 x unnecessary, can't be optimized here (IMHO).
>
> If this code is getting called often enough that optimization matters, you
> got *bigger* issues to worry about than optimization. Looks like it should
> only happen once at boot time.

Text size matters even on static storages. A Linuxbios image not fitting
to the 2M flash, etc.

Thanks.
____
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/